News   Magazin   Börse   Links   ArcArchie   Homepages
 News  Home 

Dies & Das *

<   >

Ergänzungen für VirtualRPC in Use
Ein Jahr nach der Freigabe des englischsprachigen Booklet VirtualRPC in Use als E-Book, soll nun jeden Monat zusätzliche Ergänzungen rund um den Risc PC Emulator VirtualRPC zum kostenlosen Download angeboten werden. Die erste Ergänzung kann man nun herunterladen. Für VirtualRPC Benutzer sicher eine interessante Sache.

FFmpeg und FFplay
Christopher Martin hat den Mediakonverters FFmpeg auf eine aktuelle Version gebracht. Zusätzlich gibt den es nun die erste Version des einfachen Mediaspielers FFplay.

Drag 'n Drop
Die sechste Ausgabe des PDF Magazins Drag 'n Drop kann online erworben werden.

FracNEON schneller
Michael Kübel hat an seinen Fraktalprogramm FracNEON noch etwas verbessert. Er spricht inzwischen sogar von der Möglichkeit einer Zoomdemo und schnellen 128 Bit Register für Ganzzahlen. Davon hat man vor Jahren nur zu Träumen gewagt.

RISC OS 5 für das BeagleBoard
Bei der BeagleBoard Portierung gibt es jetzt die Möglichkeit beim Booten die CMOS Konfiguration zu laden. Das Speichern der Konfiguration ist aber momentan noch etwas umständlich. Dave Higton ist aber schon dabei das die Konfiguration auch auf der SD Karte ohne Umstand gesichert wird. Dave hat nebenbei die Größe der Konfigurationsdatei schon Mal auf zwei KByte angehoben. Aber natürlich sind davon noch dreiviertel ungenutzt. Bei dieser Neuerung sind Fehler in SCSIFS ans Tageslicht gekommen. Deswegen empfiehlt Jeffrey Lee allen Benutzern der ROM Images vom Dezember oder Januar [update] das Bootlaufwerk [/update] zu formatieren um Problemen aus den Weg zu gehen. So etwas kann leider bei Entwicklungsversionen passieren. Viele A9home Benutzer kennen solche Probleme. Das ROM Image vom 27. Januar soll diese Fehler nicht mehr enthalten. Wie Raik schon richtig gemeldet hat, unterstützt EtherUSB nun offiziell den Netzwerkanschluss des BeagleBoard-xM. Über eine Systemvariable kann die MAC Adresse verändert werden, falls man mehrere BeagleBoard-xM in einen Netzwerk mit RISC OS im Betrieb hat. Tester der inoffiziellen Version sollten vorsichtshalber auf die aktuellen Version wechseln, da Thomas Milius zwischendurch einige Änderungen vorgenommen hat und die Version von a4com nicht unbedingt den letzten Stand widerspiegelt. RISC OS 5 nähert sich mit grossen Schritten zu einer Version die den Vergleich in der Benutzbarkeit mit dem IYONIX pc nicht scheuen muss.

cms, 29. 01. 2011, 18:16 Uhr <   >
@cms

Ich habe natürlich erst mal ein Backup der Festplatte gemacht aber der Fahrplan ist mir nicht klar. Wenn ich sie vom alten USB stick formatiere stellt das doch keinerlei Änderung gegenüber dem Stand von vor einem Monat dar. Davon abgesehen, daß ich danach alle Daten und Einstellungen wieder rüberkopieren muß. Soll ich wieder eine ganz neue Festplatte via RamDisk aufsetzen?
Patric, 29. 01. 2011, 19:13 Link
Mist ohne Fat32FS kann das neue ROM natürlich mit meinem Backup Stick nichts anfangen. Ich denke ich hüte mich, die funktionierende Festplatte mit allen Einstellungen, Modulen und Programmen der letzten eineinhalb Monate zu formatieren, bevor ich da mehr Durchblick habe.
Patric, 29. 01. 2011, 19:34 Link
@Patric

Du kannst das !Boot von Festplatte auf den Stick kopieren und das Boot auf der Platte sicherheitshalber in einem Verzeichnis verstecken.
Ich habe von Stick gebootet, das !Boot auf dem Stick gelöscht und das von Platte draufkopiert.
Du solltes dann, nach eine Neustart, wie gewohnt auf Alles zugreifen können. Hat bei mir gut funktioniert. Ich musste nur einige wenige Pfade anpassen, als ich damals von Tanks "FestplattenROM" zurück auf das reguläre bin.
Komischerweise habe ich nur Probleme mit dem ROM vom 25.01. bekommen. Das vom Dezember und das vom 27.01. tun es klaglos.
Ich werde mir trotzdem die Arbeit machen... Ich habe noch eine 160er Platte liegen, die in den a9home soll. Kann ich extern anschließen, sozusagen als "Brückentechnologie".
Raik, 29. 01. 2011, 19:58 Link
>RISC OS 5 nähert sich mit grossen Schritten zu einer Version die den Vergleich in der Benutzbarkeit mit dem IYONIX pc nicht scheuen muss.

Das ist mal ne Ansage ! Ein paar Fragen habe ich noch:

- Die Festplatte ist dann eine externe USB Pladde, richtig ?
- wie stabil ist das System mittlerweile, kann man damit schon arbeiten oder ist das eher noch ein Testsystem ?
- als moderner Browser steht der Firefox zur Verfügung ?
Ex-RiscOS Benutzer, 29. 01. 2011, 20:00 Link
Hmm... habe meine Festplatte nun doch formatiert und die Boot sequenz der RAM disk kopiert. Trotzdem findet er kein Boot drive und verharrt beim Startbildschirm (press ESC to cancel, nicht dem GUI Start)
Patric, 29. 01. 2011, 20:31 Link
*configure SCSIFSDrive 4

funktioniert hinsichtlich *status aber bleibt nicht über re-boot erhalten.
*save cmos resultiert in: drive empty
Patric, 29. 01. 2011, 20:47 Link
Hmm weder kann ich cmos direkt nach sd speichern (via usb adapter natürlich), noch funktioniert es, das nach einem usb stick gespeicherte cmos unter windows auf die sd karte zu speichern. Nach wie vor springt alles zu scsifs 0 zurück
patric, 29. 01. 2011, 21:03 Link
Mist mein BB ist hinüber. Sieht aus als ob die SD nicht mehr gebooted wird, alles bleibt tot.
Patric, 29. 01. 2011, 23:43 Link
Hallo Patric,

vermutlich hat das CMOS-Schreiben Deine microSD-Karte irgendwie in einen Zustand befördert, wo Booten nicht mehr möglich ist. Dann stellt sich das BB absolut tot.

Versuch' doch mal, mit dem Original-Linux zu booten. Ich wette, das funktioniert.
hubersn, 29. 01. 2011, 23:47 Link
Hallo Ex-RiscOS Benutzer,

ja, plattenspeichertechnisch geht beim BeagleBoard nur USB. Ich habe eine 2,5"-250GB-Platte dranhängen.

RISC OS 5 selbst ist mittlerweile sehr stabil, aber an der Software hapert es doch noch. Da ist Experimentierfreude gefragt, bis man sich eine ausreichende Softwareausstattung zusammengepuzzelt hat. Es erinnert doch stark an die IYONIX-Frühzeit, nur halt ohne Aemulor...

Firefox ist zwar verfügbar, aber die Qualität der Portierung ist doch eher...wie formuliere ich das nun freundlich...experimentell. Ich browse nur mit NetSurf (oder per RDP auf einer Windows-Kiste).

Ich persönlich bin sehr zufrieden mit den Fortschritten an der BeagleBoard-Front, aber m.E. braucht es unbedingt eine Lösung wie Aemulor, damit das Teil eine seriöse Umstiegsoption für IYONIX- oder gar RiscPC-Besitzer wird. Als Notlösung wird eventuell demnächst eine ArcEm-Portierung ins Haus stehen, aber das ist maximal gut genug für ganz alte Software (RISC OS 3.1).
hubersn, 29. 01. 2011, 23:56 Link
Das beruhigt mich etwas. Tatsächlich funktioniert die Karte unter Windows auch nicht. Dachte schon es geht mir wie Dave Highton und mein Kartenslot wäre hinüber. War zwar die Originalkarte aber meine andere microSD geht. Erleichterung! Jetzt mal das ROM auf diese kopiert.
@hubersn, 30. 01. 2011, 00:32 Link
sorry das da gerade war von mir
patric, 30. 01. 2011, 00:34 Link
@Patric

Geht den Menschen wie den Leuten ;-)

Ich habe es aufgegeben, die microSD fürs BBxM anders zu beschreiben, als mit SDCreate... dashalb hab ich auch 2 im Umlauf ums dort zu tun. Beim alten BB gehts von überall...

@ Hoffentlich bald Ex Ex ;-)
FP extern intern ;-)
Die von mir verwendeten Adapter (FP und DVD) sind für interne Geräte und bammeln via Hub am OTG-Port. Grundsätzlich aber nur USB.
Das System läuft bei mir sehr stabil (siehe auch weiter oben) und die Software die mir wichtig ist tuts. Ist zu viel, um es hier zu nennen ;-) Bilder auf meiner Seite... leider nicht ganz aktuell ;-)
Ich surfe auch mit Netsurf... Firefox brauche ich eigentich nur um meinen Router zu konfigurieren... also selten. Der ist lansamer, kann aber wenige Seiten besser. Leider ist P.N. etwas unzugänglich :-(
Raik, 30. 01. 2011, 01:29 Link
@ cms

Kleiner Fehler... ;-)
Jeffrey schreibt "reformat your boot drive". Das ist bei den meisten der Stick.
Ich hatte bisher keine Probleme (ausser mit dem ROM vom 25.01.), trotz sehr intensiver Tests. Allerdings haben sowohl meine 8GB Bootsticks, als auch mein 120GB (BBc4) und 160GB (xM) FP noch viel Luft. Ich werde aber mein System trotzdem neu aufsetzen.
Raik, 30. 01. 2011, 01:55 Link
habe es jetzt genauso gemacht:

https://www.riscosopen.org/forum/forums/3/topics/445?page=12#posts-6025

funktioniert! Erster Neustart klappte allerdings prompt nicht, dachte schon, jetzt sei auch die zweite Karte hin. Scheint ne heikle Angelegenheit zu sein irgendwie
Patric, 30. 01. 2011, 11:35 Link
@hubersn,@Raik: danke für die Infos.

Ich würde vom RiscPC auf das BB umsteigen. :-) Ziemlich langer Migrationspfad.
Wenn man mit einer externen Pladde unter RiscOS arbeitet, merkt man das überhaupt ? Die Datenmengen hielten sich doch immer in Grenzen ?
Ex-RiscOS Benutzer, 30. 01. 2011, 15:48 Link
Bei der Festplattengeschwindigkeit im Vergleich zum Risc PC würde ich mir keine Gedanken machen. Der Risc PC ist ob mit internen IDE oder SCSI-/IDE-Karte nicht sonderlich schnell. Bei IYONIX pc, A9home und besonders PC Benutzern sieht das etwas anders aus. USB 2 ist sicher suboptimal, aber erstmal nicht zu vermeiden. Auch wenn das BeagleBoard-xM noch Erweiterungmöglichkeiten bieten würde. Ich denke das wird in ein paar Jahren bei der Cortex-A9 Portierung gelöst.
cms, 30. 01. 2011, 16:34 Link
Habe irgendwas bei den Netzwerkeinstellungen vermasselt und komme nicht mehr zum Desktop wenn ich EtherUSB abbreche. Sollte nicht R oder Del die Booteinstellungen umgehen?
Patric, 30. 01. 2011, 18:34 Link
Nein, die Netzwerkkonfiguration steht nicht im CMOS. Die würde da auch nicht rein passen. Da sind die genutzten 240 Byte "etwas" knapp. Also das Löschen des CMOS (R, Entf) funktioniert nicht. Zusätzlich kann man noch nicht das CMOS direkt beschreiben beziehungsweise Löschen.

Bei RISC OS 4 steht die Konfiguration im Obey !Boot.Choices.Internet.Startup. Das wird bei RISC OS 5 auch so sein, auch wenn eventuell an einer anderen Stelle. Ob man die Datei einfach löschen kann (Umbennen!!!) weiß ich nicht. Das Drücken der Umschalttaste (Shift) bis der Desktop kommt überspringt !Boot beim Start - zumindestens bei RISC OS 4. Das sollte erstmal etwas helfen.
cms, 30. 01. 2011, 19:36 Link
Hallo Ex-RiscOS Benutzer,

es kommt halt immer drauf an, was man sich vom neuen Rechner erwartet und erhofft. In der Welt der PCs ist es ja üblich, dass man ständig "größer, schneller, mehr" bekommt. In der RISC OS-Welt ist das viel komplizierter. RISC OS Six hat mehr Features als RISC OS 5, läuft aber nur auf ewig alter Hardware oder unter Emulation. Der Risc PC hatte die Möglichkeit eines Zweitprozessors, keine andere RISC OS-Hardware danach hatte das. Der IYONIX brachte uns superschnelle Festplattenanbindung, das BeagleBoard macht da rückwärts. Risc PC (mit ViewFinder) und IYONIX hatten hohe Grafikauflösungen zu bieten, beim BeagleBoard muss man da tricksen und ist auf entsprechende Monitorhardware angewiesen. Dafür gibt es digitales Video-Out, das war dem IYONIX immer verwehrt und erst die letzte ViewFinder-Variante bot das für den Risc PC.

Ganz kompliziert, die ganze Geschichte. Deshalb ist es sehr schwierig, eine allgemein gültige, beste Migrationsstrategie zu empfehlen. Für manche ist es eine Emulationslösung, für manche ein BeagleBoard, für manche ein gebrauchter IYONIX.

Wenn Du sagen kannst, welche Software von Deinem Risc PC zukünftig unbedingt laufen muss, kann ich eher sagen, was für Dich passt.

Ich persönlich verwende RISC OS nur noch zur Softwareentwicklung für RISC OS, EMail und DTP-/Grafikzeugs. Bei Bedarf habe ich jederzeit Zugriff auf einen IYONIX und Risc PC sowie auf gewöhnliches Windows und x86-Linux. Deshalb ist das BeagleBoard für mich eine gute Wahl.
hubersn, 30. 01. 2011, 19:42 Link
@cms

ja, es ging auch darum, das Boot zu überspringen. Klappt leider nicht mit Shift. War da nicht mal was von wegen Tastatureingaben werden zu diesem Zeitpunkt noch nicht erkannt? Kam erst nach Löschen des cmos files wieder am Boot vorbei.

EtherUSB startete irgendwie nicht richtig, keine LEDs am NIC. Ether USB und autosense waren aber alle an der richtigen Stelle. Kann aber daran liegen, daß ich noch die ganzen !System updates sowie Toolbox etc noch nicht wieder aufgespielt hatte.
Da tat sich gar nichts.

Mal sehen, ob ich jetzt mehr Glück habe.
Patric, 30. 01. 2011, 19:42 Link
Hab ich nicht. Der BB NIC bleibt dunkel und der Rechner hängt am DHCP Vorgang. Mit ESC kann ich zwar abbrechen, kann aber nicht zum Desktop.

Benutze das EtherUSB 0.10a vom 27.11.
patric, 30. 01. 2011, 20:21 Link
einzige Idee: im Autosense SetEther Obey steht noch EtherUSB:.0.07:EtherUSB

Tatsächlich sollte es aber 0.10alpha oder 0.10a(?) heißen.

Andererseits war das mit dem alten Rom nach Austausch des EtherUSB moduls auch kein Problem.
Patric, 30. 01. 2011, 21:12 Link
@Patric

Verwendet Dein Router MAC-Adress Filter? Thomas hat die fest eingestellte MAC geändert auf 02:07:21:68:16:03.
Di alte war 00:50:C2:01:01:01.
Kannst Du später individuell ändern mittels obey im Predesk.
Allerdings solltest Du mit [ESC] jederzeit das Booten abbrechen können und mit [Chancel] weiter zum Desktop kommen. Bei mir gings problemlos.
Das EtherUSB an sich funktioniert bei mir besser, als die inoffiziellen vorher.
Raik, 30. 01. 2011, 21:21 Link
@Raik

Keine Ahnung? Allerdings funktioniert die alte EtherUSB vom a4com server genausowenig. Der NIC bleibt auch vollkommen unbeleuchted.

Ich kann zwar mit ESC abbrechen aber beim Anklicken von Cancel tut sich mal gar nichts.
patric, 30. 01. 2011, 21:31 Link
p.s.: ich verstehe auch nicht warum vigays misc setup plötzlich nicht mehr funktioniert. Statt des Acorn switcher habe ich jetztwieder die Iyonix bohne und 3D Iconbar.
Überlege wieder aufs alte ROM zurückzuwechseln bis das hier besser dokumentiert ist. Bei mir funktioniert eigentlich jetzt ziemlich viel nicht mehr
Patric, 30. 01. 2011, 21:33 Link
DOSBox geht immer noch nicht im Vollbildmodus, das wäre jetzt das Einzige was mich dazu hätte bewegen können mit diesem vermurksten Zustand weiterzuleben.
Schaue mir das nächste Woche nochmal an, jetzt kommt das alste ROM wieder drauf.
patric, 30. 01. 2011, 21:44 Link
@hubersn

Ich habe natürlich keine zu hohen Erwartungen an das BB. Zugriff auf Win/Linux habe ich, RiscOS würde ich gerne nutzen um mich wieder mit RiscOS zu beschäftigen. :-) Also Entwicklung für und unter RiscOS, Textverarbeitung und ein bisschen Bildbearbeitung. Auf die Software vom RiscPC bin ich nicht wirklich angewiesen. Festplatte und Netzwerk sollten funktionieren und der Aufwand der Installation überschaubar sein. Aber der Fortschritt zeigt ja das sich das immer mehr verbessert.

Und die Perspektive das in Zukunft weiterhin neue Hardware verfügbar sein wird, macht das verdammt interessant !
Ex-RiscOS Benutzer, 30. 01. 2011, 23:25 Link
Fehler gefunden. Natürlich erst nachdem ich zurück aufs alte ROM bin. Morgen nochmal das Ganze.
Patric, 30. 01. 2011, 23:29 Link
So, jetzt läufts. Mit CMOS und der ganzen chose ;-)
Patric, 31. 01. 2011, 19:54 Link
@Patric

Und? Was war der Fehler?
Raik, 31. 01. 2011, 20:12 Link
Ähm der Staubsauger, den die Reinigungsfachkraft am anderen Ende meines Ethernet over 240V Netzes eingestöpselt hatte ist leider nicht mit Wlan Adapter ausgestattet.
Da besagter Staubsauger dem Beagleboard aber partout keine DHCP settings zur Verfügung stellen wollte, rödelte sich EtherUSB natürlich zu Tode. Naja, wieder was gelernt.
Patric, 31. 01. 2011, 21:49 Link
@Patric
Auch ein geiler Fehler ;-)
Komisch nur, daß Du mit [ESC] nicht abbrechen konntest.
Raik, 31. 01. 2011, 22:13 Link
@Raik

Vielleicht liegt's am USB-PS/2 Adapter? ESC Abbruch erforderte immer mehrmaliges Drücken und dann ging's auch nicht mehr weiter. Und viele andere Dinge, die gestern nervten. Zum Glück war der "Fehler" ja dann leicht behoben und wenn man erst mal weiß, wie das alles geht mit ROM und CMOS, ist das Ding in unter 5 Minuten gewechselt.
Da lohnen dann auch die 6.99 für's Kartenlesegerät ;-)

Sieht jetzt eigentlich alles ganz gut aus soweit!
Patric, 31. 01. 2011, 22:37 Link
@Patric

Ich habe mehrere Tastatur / Mouse - Kombinationen durch. Es war immer so, daß einmal [ESC] reichte. Nach kurzer Zeit wird man gefragt, was man tun möchte, weil der Bootvorgang nicht volllständig war...
Mehrmahliges drücken bewirkt bei mir, daß die Abfrage entfällt und ich lande gleich im Desktop. Habs gerade probiert.
Vielleicht bootest Du auch Sachen die Netzwerk brauchen.
Wenn man mit 2 Karten arbeitet, ist der Wechsel in der Tat problemlos, zumal der BIK einen Kartenleser im Frontpaneel hat.
Raik, 01. 02. 2011, 04:19 Link
@Raik

Bei meinem BIK friert der Computer komplett ein, wenn ich 'ne SD-Karte da rein stecke und dann auf :1 klicke.
Holger, 01. 02. 2011, 06:42 Link
@Holger

Wenn alle Stecker richtig sitzen, auch an der Platine vom Kartenleser (Man kann das Frontpaneel nach vorn abziehen.), sollte das funktionieren. Möglich ist noch eine "unsaubere" Lötstelle. Die Stecker sind alle handgelötet.
Wenn Du die Möglichkeit hast, intern den Stecker des Kartenlesers vom USB-Hub abzuziehen und z.B. an einen Laptop zu stecken (ggf.mit Verlängerung), kannst du testen ob der Leser generell funktioniert.
Es kann auch sein, daß die Strombersorgung des HUBs nicht sauber funktioniert. Ggf. Detlef kontaktieren. Die Probleme sind nicht normal.
Raik, 01. 02. 2011, 08:37 Link
@Raik

Am Platinenstecker 'rumgezuppelt (ihn richtig auszustöpseln hab ich mich nicht getraut), das Kabel vom Cardreader auf einen anderen Anschluß vom Hub gesteckt, das Stromkabel vom Hub ein- und ausgestöpselt: Ergebnis 0.

Mein Laptop ist alles andere als betriebsbereit.

Mal sehen, vielleicht kann Detlef mal ein Auge 'drauf werfen, wenn wir ihn (toi toi toi) im März nach Essen bekommen.
Holger, 01. 02. 2011, 19:05 Link
@Raik

kann auch sein. Abgesehen von NetTime könnte es auch mit EtherUsb und Phoenix zusammenhängen. Der brauchte die module in einem anderen Verzeichnis als Netsurf. Insofern hatte ich EtherUsb doppelt im Boot. Hilft auch nicht unbedingt.

Jetzt läuft ja wie gesagt erst mal alles wieder so gut wie mit dem alten ROM von Tank. Weitere Programme testen hatte ich noch keine Zeit.
Patric, 01. 02. 2011, 20:49 Link
Da bei mir Programme wie SDcreate, DosBox und FTPc nach wie vor nicht, bzw nicht so wie gedacht, laufen, wollte ich der Sache jetzt mal doch auf den Grund gehen.
Dachte, daß mir !Reporter vllt einen Anhaltspunkt geben könnte.

Während des Bootvorganges werden folgende Fehler protokolliert:

Boot:Utils.PatchApp not found
Boot:Utils.UnplugTbox not found

SharedClibrary:

Unplug Internet A
Module is not in ROM

Unplug NetMsgs
Module is not in ROM

Unplug AccMsgs
Module is not in ROM

Habe also als erste Maßnahme die Tbox.zip und System.zip von der Castle Seite nochmals heruntergeladen und mit System merge installiert. Nach Neustart habe ich jedoch die gleichen Fehler
Patric, 06. 02. 2011, 09:07 Link
Beim BeagleBoard und Castle würde ich vorsichtig sein. Die sind nicht unbedingt ARMv7-fähig. Zusätzlich ist RISC OS 5 beim BeagleBoard noch eine Baustelle und da muss nicht jeder Fehler eine wichtige Bedeutung haben.

Ich würde mich zuerst immer bei ROOL (klick) umsehen. Mein Gedächnis sagt mir auch, das dort ein Boot zum Runterladen vorhanden ist.

Bei mir (A9home) ist Boot:Utils in !Boot.Utils. Stimmt sicher auch bei RISC OS 5. Dort ist PatchApp ein Modul und UnplugTbox ein BASIC Programm. Wenn "*Help AppPatcher" funktioniert, dann ist das Modul, woher auch immer geladen worden. UnplugTbox "zieht" ein paar Module aus dem ROM. Welche das sind, steht im Programm. Die Meldungen danach sagen, das dann aber doch jemand Module aus dem ROM "entfernen" möchte. Sind die Module vorhanden ("*Help Internet")? Ob das die aktuellen sind kann man via den ROOL Download (klick) vergleichen.

Ganz allgemein. Wenn man prüfen will ob ein Modul auch auf dem BeagleBoard, A9home und so weiter funktionert, kann man das einfach via Doppelklick laden. Das kann bei systemnahen Modulen einigen Schweiss verhindern. Im schlimmsten Fall muss man den Rechner neustarten und hat dabei den Mist nicht in System. Man sollte aber prüfen ob das Modul nicht schon geladen ist und die Versionsnummer mit dem neuen Modul vergleichen. Dazu das neue Modul in einen Editor laden und nicht speichern. Edit ist da nicht sehr hilfreich, geht aber zur Not auch. Mit StrongED ist das übersichtlicher. Zap??? Alternativ kann man auch Verma nehmen. Dort findet man den Modulnamen, der nicht unbedingt mit dem Dateinamen übereinstimmt, und die Version. Via "*Help Modulname" erhält man dann die Version plus aus dem geladenen Modul. Nach dem Laden unbedingt prüfen ob die Version stimmt.

Ich emfehle das Boot von ROOL runterzuladen, das in eine Verzeichnis auf dem Bootmediun auspacken, das jetzige Boot in ein weiteres Verzeichnis zu verschieben und dann das ROOL !Boot an die richtige Stelle verschieben. Das wird dann naturgemäss einiges fehlen, wie zum Beispiel die Netzwerkunterstützung. Das mußt Du dann nochmal installieren. Das alte Boot würde ich dann noch einige Zeit aufheben, da eventuell dort noch etwas wichtiges drin schlummert und erst später auffällt. Eventuell muss man noch bei den ROOL Downloads darauf achten, ob die auch BeagleBoard geeignet sind.

Achja, ein Backup von einen laufenden System, auch wenn es Macken hat, kann hilfreich sein.
cms, 06. 02. 2011, 09:52 Link
Hmm Boot und Modules sind bei ROOL als TAR gepackt. UnTarBZ2 weigert sich leider die Archive zu entpacken und bricht ab. Klar, wie sollte es auch anders sein? Mal sehen, ob ich es im Kommandozeilenmodus machen kann.
Patric, 06. 02. 2011, 11:50 Link
Mal was Anderes: warum ist NetSurf unter VRPC eigentlich so erheblich performanter als auf dem BB? Wegen der USB Festplattenanbindung oder dem USB Netzwerk?
Auf dem gut fünf Jahre alten ALDI PC(!), auf dem ich VRPC SA ersatzweise laufen habe, werden Seiten wie Spiegel Online in weniger als der Hälfte der Zeit geöffnet. Schon etwas ernüchternd angesichts des Alters und der relativ minderwertigen Ausstattung des besagten PC.
Patric, 06. 02. 2011, 16:18 Link
@Patric

Im selbstentpackenden Harddisc-Image (Typ: Utility) ist ein komplettes aktuelles !Boot etc. drin und soweit ich das überschauen kann komplett BB kompatiblen. Einfach in einem Verzeichnis Deiner Wahl entpacken...
Backup der alten Sachen ist natürlich hilfreich. Einige Sachen wie EtherUSB fehlen natürlich.

Netsurf ist bei mir auf dem xM wesentlich schneller als auf den anderen Rechnern. Keine Ahnung wo bei Dir der Wurm drin ist.
Raik, 06. 02. 2011, 19:49 Link
@Raik

Ja, an das hatte ich auch noch gedacht. Meinte aber, daß da ziemlich viele modules fehlen. Schau ich mir noch mal an.
Interessant mit NetSurf. Bei mir ist es schon merklich langsamer bei einigen Seiten.
Patric, 06. 02. 2011, 23:02 Link
@Patric

Sicher fehlen einige Module im neuen Boot, dafür ist die Struktur aber wieder sauber. Das was fehlt mußt Du halt wieder einmischen.
Vorher vielleicht mit Doppelklick testen ob kompatible...
Netsurf: Vielleicht solltest dur die Einstellungen mal kontrollieren. Zu grosser Cache bremst bei mir merklich und "Bilderanzeige" über RISC OS funktioniert bei mir am besten.
Raik, 07. 02. 2011, 11:02 Link
@Patric
Vergleichbare Auflösung und Farbtiefe eingestellt?
Raik, 07. 02. 2011, 11:46 Link
@Raik

Dachte viel hilft viel? Wieviel cache sollte denn? Guck ich gleich morgen mal wieder, ist ne gute Idee! Wegen Farbeinstellungen und so habe ich "von RISC OS verwalten" eingestellt

Zum Boot: jetzt fällts mir grad erst ein, daß ich ja die HD4 auf ein anderes Medium entpacken und dann das Bootverzeichnis rüberkopieren kann. Eigentlich doch nicht so schwer.
Eine dumme Frage aber: wie sehe ich einem Modul an, ob es kompatibel ist oder nicht? Wenn ich zB "FTP" oder "Tinct" doppelklicke wird ja weder der Rechner abstürzen noch sonst was passieren.
Höchstens, daß mir !Reporter etwas anzeigt?
Patric, 07. 02. 2011, 22:09 Link
@Patric

Wenn Du ein inkompatibles Modul "doppelklickst" bekommst Du im Regelfall eine entspr. Fehlermeldung oder der Rechner hängt sich auf. Nach Reset/Neustart ist alles beim Alten.
Rennt das Modul, siehst Du es, wenn Du in der CLI die Liste aufrufst.
Das klappt eigentlich immer.
Bindest Du ein inkompatibles Modul in Boot ein, hat du evtl. die A-Karte.
Raik, 07. 02. 2011, 23:03 Link
ArcSite   News   Magazin   Börse   Links   ArcArchie   Homepages